Ford Enthusiast Unofficial Resource

Go Back   Ford Forum - Enthusiast Forums for Ford Owners > Past Ford Models > Aspire/Festiva/Fiesta
Sign in using an external account
Register Forgot Password?
Search


Welcome to Ford Forum!
Welcome to Ford Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #11  
Old 01-12-2007, 12:27 AM
 
Join Date: Jan 2007
Posts: 7
Default RE: Check engine Light

I went for a junkyard hunt and pulled a complete switch assembly from a 1997.It looked in rough shape compared to mine.I've installed it and thus far after about 40 miles of driving,the light has stayed out.
Cross my fingers and will give it tomorrow before I take it in for a smog check.
To be continued...
Reply With Quote
  #12  
Old 01-12-2007, 03:55 PM
 
Join Date: Jan 2007
Posts: 7
Default RE: Check engine Light

Damn....Check Enf light back on and again P0470!!!
What next??
Reply With Quote
  #13  
Old 03-22-2011, 03:47 PM
Junior Member
 
Join Date: Mar 2011
Posts: 1
Default 1997 Ford Aspire P0470 code

I have a 1997 Aspire that had a check engine light and a P0470 error code,it's a misleading code i removed the EGR started the car the exhaust port was fine the intake port barely had any suction.I used and old trick when the engine is hot brought the RPM up to about 1500 then from a spray bottle sprayed water into the port to causing stream to clean it,once done i could feel hard suction i also replaced the EGR not sure i had to but the car has 88000 miles on it,but the light was still on so i disconnected the battery all night to make sure the computer was totally clear.Then in the morning i started the car let it warm up without touching the gas pedal drove it for about 40 miles then took it out on the highway for 5 miles at 55 mph let it coast to 20 then slowly up to 60 mph for 5 miles then coasted to 20 then fast up to 65 mph for a short distance a highway cycle no check engine light still so i drove right then to the emission test center the car passed all tests.
Before i did this i took it to a mechanic that bragged about his $10,000 machine had the car for a week,he said he couldn't figure it out and you can't get the EGR solenoid for that car anymore well that wasn't it.
But a huge help was the service manager at Roesch ford in Elmhurst IL.I'm not being payed by them they helped me for free i guess they figure do like they used to do in the old days help someone and you get payed back with word of mouth.
Reply With Quote
Old 03-22-2011, 03:47 PM
 
 
 
Reply

Tags
2003, aspire, code, engine, failed, fails, focus, ford, light, milcheck, p0470, p1195, probe, smog, test, windstar

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Our Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 06:40 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

SEO by vBSEO ©2010, Crawlability, Inc.