E-250 defrost / heat blower quit working - Ford Forum - Enthusiast Forums for Ford Owners
Ford Enthusiast Unofficial Resource

Go Back   Ford Forum - Enthusiast Forums for Ford Owners > Ford Trucks, Ford Vans & Ford SUV's > Ford Econoline E Series
Search



Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-29-2004, 01:25 AM
 
Join Date: Sep 2004
Posts: 1
Default E-250 defrost / heat blower quit working

Hello all,

I have a 2000 E-250 van. The heater/defrost blower worked fine when I got it.. Then 1st, 2nd, and 3rd speed quit working on the fan switch. Now the high setting for the blower won't work.. . I checked in the power distribution box, the fuse was fine... i also switched the larger plug with the one for the horn.. is it a fan motor, bad switch or something else i'm missing.? I do have power coming to the switch.

Thanks for your suggestions,

Rick
Reply With Quote
  #2  
Old 12-21-2004, 10:45 PM
 
Join Date: Dec 2004
Posts: 2
Default RE: E-250 defrost / heat blower quit working

I have the samew problem on mine but I still have "hi" speed. It's the rheostat, the dial switch that's bad. You could bypass it with a generic switch from Autozone or somewhere like that or just spend a few more bucks on a new one at the Ford Shop.
Reply With Quote
  #3  
Old 09-08-2005, 12:04 AM
PTT PTT is offline
Junior Member
 
Join Date: Sep 2005
Location: missouri
Posts: 21
Default RE: E-250 defrost / heat blower quit working

My 10 year old E150 conversion van did the same thing and it was the blower motor resistor. The lower speeds went out, then high speed quit. Replaced it and all was well for a month then blower motor kacked out! Good luck.
Reply With Quote
  #4  
Old 09-11-2005, 12:27 AM
 
Join Date: May 2005
Location:
Posts: 298
Default RE: E-250 defrost / heat blower quit working

yes sounds like thermal switch first the low speeds go and eventually high as well
Reply With Quote
  #5  
Old 09-30-2005, 02:47 AM
 
Join Date: Aug 2005
Posts: 47
Default RE: E-250 defrost / heat blower quit working

So your lower speeds went first until nothing worked......
My pattern went like this.....blower moter worked on lower speeds fine, but when switched to fast speed it would work a few minutes then blow fuse. This continued for about 5,000 miles (several months) until nothing worked. Replaced switch....wasn't that (I did this because I already had an extra switch and that was easier than going for the motor just in case).

No such luck, put a new blower in and Bingo! Works!


__________________
Doyle O. Bailey
Reply With Quote
  #6  
Old 09-30-2005, 11:45 PM
 
Join Date: May 2005
Location:
Posts: 298
Default RE: E-250 defrost / heat blower quit working

blower motor resistor is called a thermal switch because it uses heat as its resistor
Reply With Quote
  #7  
Old 12-22-2005, 03:14 PM
 
Join Date: Dec 2005
Posts: 4
Default RE: E-250 defrost / heat blower quit working

its the resistor switch under hood easy to fix.had the same problem 2 screws hold it on
Reply With Quote
  #8  
Old 12-23-2005, 02:47 AM
 
Join Date: Jul 2005
Location:
Posts: 608
Default RE: E-250 defrost / heat blower quit working

yeppers mine lost hi speed first , real easy to replace, sometimes the connecter plug is a tad rough getting off
Reply With Quote
  #9  
Old 07-23-2007, 01:28 AM
 
Join Date: Jul 2007
Posts: 2
Default RE: E-250 defrost / heat blower quit working

Ok so I have the same problem! However fuses are good. Changed the thermal resistor and at the same time I figured I might as well change the motor fan. Still does not work what else do I check now. I noticed the lights for the switches is out. Could the speed switch be the problem?

Help! Any ideas would be appreciate it!
Reply With Quote
  #10  
Old 11-07-2008, 05:19 PM
Junior Member
 
Join Date: Nov 2008
Posts: 3
Default RE: E-250 defrost / heat blower quit working

Quote:
ORIGINAL: jezzy

its the resistor switch under hood easy to fix.had the same problem 2 screws hold it on
is it behind the battery about 4 o'clock to theblower fan?
Reply With Quote
 
 
 
Reply

Tags
1993, 2002, blower, defrost, defroster, e250, e350, f150, ford, heat, motor, quits, replace, rheostat, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Defrost wont blow heat only cold Purplekangaroo1 Ford Taurus 6 11-12-2012 01:49 PM
cruise control, turn signal, blower, shift out of park all quit frankencow_1 Ford Contour 0 03-09-2009 11:06 PM
1998 Ford Contour heat/defrost opalgirl26 Ford Contour 2 02-08-2009 10:41 AM
non working items (wipers and rear defrost) UPDATE! RealFnCool Ford Focus 0 10-25-2007 06:44 PM
99 SUper Duty V-10 Speedo Quit working brocan Ford F-250 & Ford F-350 4 01-02-2007 09:40 PM

 
Advertising
Our Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 02:45 AM.