Ford Enthusiast Unofficial Resource

Go Back   Ford Forum - Enthusiast Forums for Ford Owners > Ford Trucks, Ford Vans & Ford SUV's > Ford Escape
Sign in using an external account
Register Forgot Password?
Search


Welcome to Ford Forum!
Welcome to Ford Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-29-2014, 06:49 PM
Junior Member
 
Join Date: Jan 2014
Posts: 1
Default 2003 Ford Escape

I have a 2003 Ford Escape which was misfiring and I found that oil was leaking in to the spark plug chambers. So I replaced all of the seals, replaced the sparks plugs, the PCV, and the ignition coils. Drove the escape around for 2 days no misfires took it and got it emissions tested, which it passed. Then my wife tried to drive it the next day and wouldn't go over 15 MPH, ( I'm guessing limp home mode), pulled the codes and said it was misfiring again. Checked to see if it was leaking oil into the chamber again and it wasn't. I then cleared the code to see if it would come up again and it hasn't yet but still won't go over 10-15 mph. I am thinking it has something to do with the PCM, Any help or ideas?
Reply With Quote
  #2  
Old 01-29-2014, 09:18 PM
Senior Member
 
Join Date: Mar 2013
Posts: 283
Default

Your cats are plugged I am sorry to say.
__________________
Check out all my Ford Tech Repair Videos @
http://www.youtube.com/user/FordTechMakuloco/videos
Please Subscribe. Always something new and interesting!
Reply With Quote
Old 01-29-2014, 09:18 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Our Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:04 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

SEO by vBSEO ©2010, Crawlability, Inc.