Ford Enthusiast Unofficial Resource

Go Back   Ford Forum - Enthusiast Forums for Ford Owners > Ford Trucks, Ford Vans & Ford SUV's > Ford Expedition
Sign in using an external account
Register Forgot Password?
Search


Welcome to Ford Forum!
Welcome to Ford Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-23-2009, 08:16 PM
Junior Member
 
Join Date: Oct 2009
Posts: 9
Default 4x4 H/L lights flashing

Hey all,

got an '06 expedition. the other day, the battery died and had to jump. After, the radio quit and the 4x4 high and low lights on the dash started flashing 3 times per every couple of minutes. Found the blown fuse (1 of 3) for the radio and am thinking that something else fried during the jump. Can't switch at all throughout the 4w range. Pretty sure it's stuck in 2H or AWD. Any suggestions?


Found the problem. Since I work at the plant where this thing is made, I asked a repairman for some help. He said that there are two fuses for the 4 wheel drive system. One of them was blown. Now it works. So now I have to ask myself why did these fuses blow out over a simple jump start? And here's another question, why doesn't the owner's manual completely list which fuses do what and have multiple listings for specific operations?

Last edited by JayB954; 11-02-2009 at 08:00 AM. Reason: found problem
Reply With Quote
Old 10-23-2009, 08:16 PM
 
 
 
Reply

Tags
4w, 4x4, blinkng, escape, expedition, explorer, flash, flashes, flashing, ford, high, lights, lo, low, ranger

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Our Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 03:21 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

SEO by vBSEO ©2010, Crawlability, Inc.