Ford Enthusiast Unofficial Resource

Go Back   Ford Forum - Enthusiast Forums for Ford Owners > Ford Trucks, Ford Vans & Ford SUV's > Ford Expedition
Sign in using an external account
Register Forgot Password?
Search


Welcome to Ford Forum!
Welcome to Ford Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-16-2010, 08:49 AM
Junior Member
 
Join Date: Dec 2010
Posts: 2
Default Shift Lock

I have a 2007 Expedition and the shift lock switch isn't releasing everytime I step on the break. I read the owner's manual and it mentioned the rear break lights. Sometimes they come on and sometimes they don't. So, when the lights don't come on, the switch doesn't release the gear shift. I keep pumping the peddle till the lights come on and then the shift lock switch will release the gear shift and I can move it out of park. I tried checking fuses and couldn't find any blown. Any advice?
Reply With Quote
  #2  
Old 12-16-2010, 12:15 PM
Senior Member
 
Join Date: Jun 2010
Posts: 5,259
Default

As you already know the brake switch also releases the shift interlock. More than likely the switch either may need to be adjusted or the switch is on it's way out. They aren't very expensive compared to not being able to get out of a place and get going.
It might be a good idea to check for a loose connection at the switch itself before going out and getting another one.
Reply With Quote
  #3  
Old 12-17-2010, 03:23 PM
Junior Member
 
Join Date: Dec 2010
Posts: 2
Default

Thanks Hanky,

I took a look at the switch. Removed it and reset it. It now seems to work. Must have worked itself loose a little I guess. Thanks a bunch.
Reply With Quote
  #4  
Old 12-31-2010, 05:43 AM
Junior Member
 
Join Date: Dec 2010
Location: Long Island, ny
Posts: 2
Default

That happened to me a few times, i messed with the switch and then it worked. The last time I could not get it working so I had to change it.
If you have to change it buy it from ford, I bought the first one at advanced auto and it was a no name switch for less then half the price of the ford switch but it didn't work, drove me nuts untill the guy at ford told me that happens alot with the cheap switches
Reply With Quote
Old 12-31-2010, 05:43 AM
 
 
 
Reply

Tags
2007, 2010, edge, excursion, f150, ford, fusion, hundred, lock, locked, release, shift, shifter, switch, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Our Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 06:34 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

SEO by vBSEO ©2010, Crawlability, Inc.