Ford Enthusiast Unofficial Resource

Go Back   Ford Forum - Enthusiast Forums for Ford Owners > Ford Trucks, Ford Vans & Ford SUV's > Ford F-150
Sign in using an external account
Register Forgot Password?
Search


Welcome to Ford Forum!
Welcome to Ford Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-17-2005, 04:02 PM
 
Join Date: Oct 2005
Posts: 1
Default 94 F150 Oil pressure gauge problem

I have a 94 F150 with 130,000 miles, still runs smooth. Just noticed that after about 5 minutes running, the oil gauge bounces a little then goes dead. There is no ticking or noise from the engine, and if I stop the engine, wait a minute, start it back up, the gauge goes to normal for about 2 minutes, then goes dead again. I replace the oil sending unit twice, and still the same. Is it the actual gauge thats bad, or is there a relay in between that I am missing??? Any help would be great!

Thanks, Kevin
Reply With Quote
  #2  
Old 10-19-2005, 04:40 AM
 
Join Date: Oct 2005
Posts: 5
Default RE: 94 F150 Oil pressure gauge problem

1990 150k mine does the same thing, its probably the gauge not the oil or you would have all kinds of trouble the lifters hammering away dry just for beginners. check the wire from the sensor to see if it might be rubbed off and bouncing arround grounding out, even just a small rub will cause all kinds of headache. otherwise it will probably end up like mine I just hope the idiot light works if I do have a problem.
if you get pressure when you rev the engine it could be a problem like old oil or worn pump.
my fuel gauge did the same thing about 3 months after the oil and now I think the temp gauge is staying right in the middle, I need to check it next time I drive it. by your description you probably have the same issue I do. I priced the gauges at 400.00 from the dealership as a package with a core. not worth it to me. just pour in the 100.00 gas every monday and hope it blows up before next week so my wife will let me get a new one.
probably not a great help but for what its worth.

Eric
Reply With Quote
Old 10-19-2005, 04:40 AM
 
 
 
Reply

Tags
30, 94, bouncing, f150, fluctuation, fluctuations, ford, gage, gauge, guage, jumping, missing, oil, pressure, problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Our Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:52 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

SEO by vBSEO ©2010, Crawlability, Inc.