Ford Enthusiast Unofficial Resource

Go Back   Ford Forum - Enthusiast Forums for Ford Owners > General Ford Forums > General Tech
Sign in using an external account
Register Forgot Password?
Search



Welcome to Ford Forum!
Welcome to Ford Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-25-2006, 01:28 AM
 
Join Date: Oct 2006
Posts: 2
Default 2003 EXPEDITION - WON'T START

HELP!!!! My '03 Expedition won't start. I get nothing from the starter not even any clicking. I replaced the battery and starter. Still nothing. I have power to all the accessories, but I get nothing when I try to start it. The Ford dealer where I had it towed can't figure it out. HELP!!!
__________________
DB
Reply With Quote
  #2  
Old 10-25-2006, 05:55 AM
 
Join Date: Jul 2006
Location:
Posts: 834
Default RE: 2003 EXPEDITION - WON'T START

Sounds like the starter relay.[hr] Follow the positive cable to it.
__________________
94 4x4 ranger
Reply With Quote
  #3  
Old 10-25-2006, 01:51 PM
 
Join Date: Oct 2006
Posts: 2
Default RE: 2003 EXPEDITION - WON'T START

Thanks for the quick response. I forgot to mention that the Ford dealer told me that their computer would not even talk to my car.
__________________
DB
Reply With Quote
  #4  
Old 10-25-2006, 02:58 PM
 
Join Date: Jul 2006
Location:
Posts: 834
Default RE: 2003 EXPEDITION - WON'T START

It still may be the relay.[hr]It still should crank if the computer was bad.
__________________
94 4x4 ranger
Reply With Quote
  #5  
Old 11-14-2006, 09:28 PM
 
Join Date: Nov 2006
Location:
Posts: 59
Default RE: 2003 EXPEDITION - WON'T START

Check for a good ground. do you have lights
__________________
79 Cobra mustang
79 Mercury Capri Drag car
03 Super crew 4x4
03 Mustang Gt
96 Ranger 4x4
Reply With Quote
Old 11-14-2006, 09:28 PM
 
 
 
Reply

Tags
2003, 2006, check, clicking, crank, expedition, location, placement, relay, sionoid, sound, start, starter, symptoms, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Our Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:49 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.