Ford Expedition The Expedition provides the feel of a full size truck with the seating of a large SUV.

2006 Expedition wonít remote start after pressing the unlock button

  #1  
Old 05-19-2019, 06:56 PM
Junior Member
Thread Starter
Join Date: May 2019
Posts: 1
Default 2006 Expedition wonít remote start after pressing the unlock button

Hi,

I own a 2006 Ford Expedition xlt. The remote starter is an avital 477L, which worked just fine until last week. I disconnected the battery because I had to replace the ac compressor myself, as I have been to 3 shops and nobody could find a compatible compressor, and the last one charged me 1200$ for the job. After replacing the compressor and the belt, the car started acting funny.
First thing was that it wonít remote start, I read each and every manual about the avital, nobody encountered this specific problem. After unlocking the car, it wonít remote start, but after I turn the keyfob to acc on, then remove the key, itíll start just fine until next time i lock/unlock after leaving it for a
few hours. There is no valet mode indicator on the remote, and I tried reprogramming it with the reprogramming button located under the steering wheel, that also didnít work. I also located the kill switch and flipped it to the moon and back, still nothing. I went to some shop and they were charging 100$ diagnose, plus extra for labor and fixing the thing. A new remote starter with install is 300$ at best-buy.
The other thing is that the engine randomly stalls, when the ac is set to max. The belt seems to be ok, everything in place and tight enough, nothing is sagging. A friend of mine suggested that I should replace the fuel filter(the car was bought from an auction site, ex police vehicle) because that might be the culprit, and my mom didnít bother to change it, she just did an oil change. I donít think itís the fuel filter, because it acted fine prior to replacing the compressor, just that I didnít have ac. The new compressor has a smaller footprint, the rotating part, and thatís why I bought a new belt, to compensate the smaller footprint. Again, everything seems a tight fit. Battery is a year old, didnít have that checked but I donít think it should be the problem.

Please help, if anyone has any suggestions, itís annoying that I cannot remote start because when I usually leave home there are around 105 degrees. Also, last night I almost ran a pole down because the car just stalled while I was making a left in the intersection and couldnít steer. I tried remote starting with and without the ac on, same issue. If I run the ac on normal, everything seems to be fine with the stalling thing, but still wonít remote start.
 

Last edited by Frantz Constantinescu; 05-19-2019 at 07:44 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
easytoremember
Ford Explorer
4
12-28-2016 12:26 PM
kdixon1029
Ford Expedition
0
03-31-2011 11:21 AM
Jesse McPherson
Ford Econoline E Series
1
11-01-2010 03:57 PM
bigcars
Ford Crown Victoria
5
07-12-2010 10:17 PM
Czecher01
General Tech
1
01-18-2006 06:05 AM


Thread Tools
Search this Thread
Quick Reply: 2006 Expedition wonít remote start after pressing the unlock button


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.