Ford Forum - Enthusiast Forums for Ford Owners - View Profile: bluewind

bluewind bluewind is offline

Senior Member

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. ncfordowner1965
    11-14-2012 08:05 AM - permalink
    the code came up as P0174, my expedition runs good, but seems to loose a little power going up hills

About Me

  • About bluewind
    Biography
    I grew up in Germany and moved to the us in the eighties
    Location
    Iowa
    Interests
    fixing bicycles and our own cars, watching F1
    Occupation
    Just Over Broke
  • Signature
    Bluewind

    "It is important to know the difference between 'precise' and 'accurate', even if you are neither!"

    Our family vehicles:
    '05 Pontiac Vibe
    '08 Hyundai Sonata 4cyl
    '10 Ford Focus
    '97 Mazda B 2300
    Previously owned:
    '00 Ford Contour SE, 2L,'98 Mazda Protege, 1.5L 5 speed, '03 Windstar, '94 Aerostar XLT 4L, '89 Geo Prizm, '86 Mazda 323 DX, 5 speed, '86 Chevrolet Cavalier, '81 Mercury Capri I6, VW 1302, Peugeot 304 (2), VW 1300, BMW R26, Hercules MK 4


Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 03-13-2018 02:28 PM
  • Join Date: 09-06-2011
  • Referrals: 1
Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.