99 Ford contour sputtering and surging at freeway speeds. - Ford Forum - Enthusiast Forums for Ford Owners


Ford Contour While only built on a short time span, the Contour was very popular with people of all driving styles, from the base model making for a great family car, to the SVT making a great track toy.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-01-2018, 08:07 PM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 2
Default 99 Ford contour sputtering and surging at freeway speeds.

i have a 99 Ford contour se 4 cylinder that sputters and surges at freeway speeds. I have replaced the fuel injectors and spark plugs but that did not resolve the issue. Any ideas what could be wrong?
Reply With Quote
  #2  
Old 04-01-2018, 11:35 PM
Junior Member
 
Join Date: Apr 2018
Posts: 2
Default

Have you checked the fuel pump? If you don't have a pressure gauge you can pull the hose near the fuel rail and hit the key without starting, it should at least give you a steady/strong stream

Or filter? Not sure right now if the filter is part of the pump, but some of the older ford models had a separate filter in the engine compartment.
Reply With Quote
  #3  
Old 04-02-2018, 09:16 AM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 2
Default

Quote:
Originally Posted by justin_b31 View Post
Have you checked the fuel pump? If you don't have a pressure gauge you can pull the hose near the fuel rail and hit the key without starting, it should at least give you a steady/strong stream

Or filter? Not sure right now if the filter is part of the pump, but some of the older ford models had a separate filter in the engine compartment.
I will be checking them today. The filter is outside the gas tank and the pump is inside.
Reply With Quote
  #4  
Old 04-03-2018, 10:21 PM
Junior Member
 
Join Date: Apr 2018
Posts: 2
Default

Oddly enough, I picked up my mom's 95 Contour GL (with 2.0L) Sunday to be my daily driver. After driving it 40 miles from her house to mine without issue, I went online to find some more info on the car. Found your post and responded.

The car hasn't been registered for over 9 years so I figured I'd clean it up and take it for emissions (smog) testing this weekend. My son decided he wanted to take it for a spin today, but couldn't get it started. I go out tonight after work and got it started, but it sputtered like it's missing a cylinder. BAH! The battery is near dead so I pulled it and put the charger on it.

Since I hadn't had much time to look around while it was running, it's hard to say what happened in two days of sitting in my driveway but I did pull the air box and everything going to the throttle body. Noticed that the PCV hose going into the air filter box was disconnected and hanging.

Will update after the battery's charge is full.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ford Galaxie 302 Sputtering and Dying FordGalaxie885 Fairlane/Falcon/Galaxie/Gran Torino 11 05-28-2013 08:19 AM
Loud Noise From Front End At Freeway Speed (2006 Explorer) grk_b747 Ford Explorer 1 11-22-2011 02:24 PM
E150 Cruise turns on and sets then speeds up and shuts off tcrate Ford Econoline E Series 0 09-09-2011 07:11 PM
88 Mustang sputtering and fuel/oil gauge amendoca Ford Mustang 0 03-11-2008 05:23 PM
auto downshift hard on freeway eric Ford F-150 3 10-22-2005 01:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 01:06 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.