2000 Mercury GM 4.6 no start, suggestions? - Ford Forum - Enthusiast Forums for Ford Owners

Go Back  Ford Forum - Enthusiast Forums for Ford Owners > Ford Cars > Ford Crown Victoria
Reload this Page >

2000 Mercury GM 4.6 no start, suggestions?

Ford Crown Victoria The crown victoria, the choice of police forces all over the United States due to its size and available V8 engine

2000 Mercury GM 4.6 no start, suggestions?

Reply

 
 
 
  #1  
Old 06-07-2018, 04:08 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 1
Default 2000 Mercury GM 4.6 no start, suggestions?

Just joined the forum, have been reading but now I have my own issue to solve. Just bought a non running Mercury Grand marquis, has 74k miles but does not start/stay running. Previous owner said he drove it daily until it started giving him issues and shut off one day. He said it seemed fuel delivery related so he got the fuel pump replaced. When the problem wasnít fixed, the car was parked. Itís been there for id say 4 months or so. The gas still smells good. Iíve heard ignition switches are common problems, so I replaced that. Also got a new a battery for it. Upon trying to start it the first time, cranks but doesnít fire. Got out and saw gas all over the floor, realized the fuel pressure regulator was missing. I found it and reinstalled. With the regulator on, I could get the car to run maybe 5 seconds, just kinda sputters and dies. After trying to prime the fuel pump a few times by turning the key, the regulator itself was blown out of the fuel rail and spewed gas everywhere. This happened more than once. Iím wondering if Iím putting the regulator in incorrectly? Could the regulator itself be faulty? My local Napa store says theyíve only sold 1 of these within the last 1.5 years at all 33 stores near me.. doesnít seem too common. Any suggestions would be appreciated. Thanks yíall.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Anna Feline Ireland
Windstar/Aerostar
6
01-12-2018 08:18 AM
Derrick Calloway
Off Topic
3
05-15-2012 10:50 AM
searchlight4759
General Tech
0
01-12-2012 10:41 AM
ndcarguy
New Member Area
3
12-10-2011 07:30 AM
joesixpack123
Ford Taurus
3
04-19-2011 07:14 PM


Thread Tools
Search this Thread
Quick Reply: 2000 Mercury GM 4.6 no start, suggestions?


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.