Ford Expedition The Expedition provides the feel of a full size truck with the seating of a large SUV.

Did I fry PCM? 2003 expedition

  #1  
Old 02-20-2019, 01:17 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Default Did I fry PCM? 2003 expedition

Went to start my 2003 5.4 expedition today, turned key and had full interior power as far as I could tell, but no crank. Cabin lights did not dim when trying to start.

I then went to check pcm relay. I DID NOT UNHOOK THE BATTERY!!! I pulled out the relay, did not look terrible, fumbles around and put it back in. Went to turn key and no dash lights EXCEPT airbag lights and gauges would go all the way up. Also new at this time is the vehicle would not shift out of park which it did prior to me messing with the relay.

I was clearly worried at this point needless to say. Eventually replaced PCM relay with another I had and all acts normal initially. Key in ignition with door open and alarm is dinging, advance key to on and dash lights up normally, than turn to start and it often seems like it just tries to turn over and then instantly power mostly cuts off, like a switch. It won’t act properly again until I remove negative battery terminal and it seemingly resets. The initial relay once I retried it still acts like it did after my initial mistake. Replace in the second relay and it does above sequence in this paragraph.

So is it likely the computer is fried?

I expect some chastisement for my lack of cautiousness with my vehicles electronics. I will now try to always remove key, disconnect battery, and reconnect battery while key is removed!

Thanks for your time!
 
  #2  
Old 02-20-2019, 03:19 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Default

Fixed... dead battery and or bad connection
 
  #3  
Old 02-21-2019, 08:01 AM
Hayapower's Avatar
Super Moderator
Join Date: Jul 2006
Posts: 6,268
Default

Thanks for the update..
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
James Chaney
New Member Area
1
08-13-2017 04:27 AM
andrew123
Ford F-150
0
01-03-2007 12:02 AM
apollo
Ford Ranger
1
10-25-2006 11:40 PM
daveranger
Ford Ranger
5
10-21-2006 03:27 PM
EFfalconsrule
Off Topic
3
01-05-2005 11:53 PM


Thread Tools
Search this Thread
Quick Reply: Did I fry PCM? 2003 expedition


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.