EGR Valve and Limp mode - Ford Forum - Enthusiast Forums for Ford Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-27-2017, 11:33 AM
Junior Member
Thread Starter
 
Join Date: Apr 2017
Posts: 1
Default EGR Valve and Limp mode

My 05 500 had a CEL. The code was for the EGR valve. Before I was able to change it the car went into fail safe mode. I changed the EGR yesterday and the car ran great. got in it this morning and started it up and it went right back to fail safe mode. Assuming that I didn't miss hooking up a vacuum line or connector, does anyone have any suggestions on where to start?
Reply With Quote
  #2  
Old 08-11-2017, 07:25 PM
Junior Member
 
Join Date: Jan 2015
Posts: 17
Default

Did you try disconnecting the battery and touch the pos and neg cables together to cancel the code?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Truck keeps going limp jrvane1 Ford Forum Help & Suggestion Center 0 02-20-2017 06:51 PM
93 F-250 E4od in limp mode whatusername Ford F-250 & Ford F-350 12 02-16-2016 11:43 AM
05 F250 EGR codes and has an EGR Delete? fordwoman99 Ford F-250 & Ford F-350 1 03-03-2013 06:24 PM
2005 f250 limp mode alex1970 Ford F-250 & Ford F-350 0 05-12-2009 09:59 PM
Limp home on a '03 T-bird hermannthegerman Ford Thunderbird 1 07-10-2008 06:46 PM


Tags
egr, fail safe mode

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 03:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.