Ford Excursion 7.3 ...engine won't start - Ford Forum - Enthusiast Forums for Ford Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-25-2017, 08:45 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 4
Default Ford Excursion 7.3 ...engine won't start

Driving along about 70MPH and the engine power just died.
Steering wheel still functioned(which it shouldn't if I lost power)
Glow plugs work and engine turns over but it won't start
Had to have it towed to a garage.They can't find the problem diagnostically because the engine won't run.
Sounds electric to me....maybe a sensor?
thanks
Tom
Reply With Quote
  #2  
Old 09-25-2017, 10:10 PM
Hayapower's Avatar
Super Moderator

 
Join Date: Jul 2006
Posts: 5,348
Thumbs up

Welcome to the site Tom..

The steering will still work if the engine dies, but you won't have power assist..
What year 7.3? Mileage etc..
Any check engine light prior to the stall?

There's actually quite a few things they can/should check diagnostically for a no start condition with a capable scan tool. Or that the scan tool can actually communicate, or any stored codes that may exist and point to a direction to go. As well as basically looking for some needed system values for a start/run condition. HPOP pressure being one, as well as a few other items can be checked/viewed without an engine run.

With no CEL prior (?), on a stall, fuel delivery may be suspect and should be confirmed, a few system start parameters being met, and the possibility of a electrical/component fail issue,, but the causes for a stall can be many..

First,, Do you hear the Fuel Pump Module 'run sound' when the key is cycled On? Module is frame mounted under about where the driver sits..
Reply With Quote
  #3  
Old 09-26-2017, 07:44 AM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 4
Default

Thx for welcome and suggestions,Hayapower.
The vehicle is a 2002 and mileage is 212,000.
The engine light didn't come on prior or during the stall.
Reply With Quote
  #4  
Old 10-03-2017, 11:03 AM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 4
Default

Found the problem.it was the IDM.
Replaced and it strated right up
Thx for the suggestions
Tom
Reply With Quote
  #5  
Old 10-03-2017, 01:28 PM
Hayapower's Avatar
Super Moderator

 
Join Date: Jul 2006
Posts: 5,348
Default

Thanks for the update,,

IDM health/response should have been available on initial diagnostics and functional testing even without a running engine.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 Excursion Limited liftgate won't lock. marc0820 Ford Excursion 0 12-28-2011 11:48 AM
2004 Ford Excursion Diesel 6L engine starts but won't run Laura W New Member Area 5 09-21-2010 09:33 PM
'04 Excursion Won't Start jrc411 Ford Excursion 3 05-28-2009 11:15 PM
Excursion Tailgate won't open cglad1 Ford Excursion 0 04-10-2007 04:29 PM
2002 Excursion Diesel won't stay in park 2excowner Transmission 0 12-06-2005 05:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:16 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.