Cluster/trans - Ford Forum - Enthusiast Forums for Ford Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-18-2017, 07:02 AM
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 1
Default Cluster/trans

I have a 05 freestyle and when I'm driving the speedo will drop out along with the miles and the abs and traction control light will come on. But right be for the cluster problems you fell a slight jolt from the trans. Then the wrench will shows about 5-10mins later if you do not stop and restart the car. It will also will not shift if you don't stop and restart the car fallowing the wrench light. Any ideas? I'm thinks it's something to do with the ECM but not sure.
Any in put is greatly appreciate it thanks.
Reply With Quote
  #2  
Old 03-18-2017, 11:39 AM
Senior Member
 
Join Date: Jun 2010
Posts: 7,555
Default

Since so much is dependent on correct info from "vehicle speed sensor", that might be a good place to start looking.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale 72 - 460 motor & trans - For sale 60's 430 motor & trans conanalois PRIVATE For Sale / Trade Classifieds 0 08-31-2013 06:16 AM
standard gauge cluster to tach cluster? blondiez24 Ford Escort 0 02-11-2008 12:01 PM
Instrument Cluster 95 Ranger gpressick Ford Ranger 0 07-14-2005 06:05 PM
Instrument cluster cluster jtt3769 Ford Ranger 2 06-04-2005 12:12 AM
Cluster for an XL DaveD Ford F-150 2 12-13-2004 03:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 07:56 PM.