Blower motor runs when key is off - Ford Forum - Enthusiast Forums for Ford Owners


Windstar/Aerostar The beginning of the minivan for Ford.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-20-2018, 10:29 AM
Member
Thread Starter
 
Join Date: Feb 2012
Posts: 42
Default Blower motor runs when key is off

Encountered a new electrical problem today. While driving to work I had the defroster on full blast (it's icy cold here) but on the way to my destination the blower speed fell back to low on it's own. When I pulled up to work and turned the engine off the blower went back to full speed and I could cycle the blower through its various speeds without a problem. Additionally, when I shut the key off, the fuel and temperature gauges went past "empty" and "cold", just the same as a VOM would do if you reversed polarity on the leads. Normally the gauges just go to the bottom of their range. Now they go past it. I've had to disconnect the battery to keep it from feeding the blower motor continually.

Anyone ever had a problem like this?
Reply With Quote
  #2  
Old 02-22-2018, 04:18 PM
Senior Member
 
Join Date: Jun 2010
Posts: 8,198
Default

Did you forget about the moisture problem doing strange things ? Sounds like your gremlin has returned, check that GEM module.
Reply With Quote
  #3  
Old 02-23-2018, 06:30 AM
Member
Thread Starter
 
Join Date: Feb 2012
Posts: 42
Default

Yup, it was moisture all along. Found some rust on one of the six relays of the interior fuse/relay panel. A little further investigation showed more water in the area. I've had to temporarily seal a leak around the windshield until it warms up enough to do a proper repair. I removed all six relays, dried out their mounts with some compressed air and replaced the rusted relay. Everything's working fine...for now.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Runs rough but runs Screenwriter Ford F-150 1 12-08-2016 08:37 PM
5.8L Crank it up, runs rough, jumps, shirks, soot out talipipe, unplug cyl. 3 runs better?? SAMF Ford F-250 & Ford F-350 2 12-08-2016 05:41 PM
Motor Runs when Ignition Turned Off DubbyDub Ford Econoline E Series 0 08-26-2015 08:30 PM
Pump In Fuel Tank Runs Constantly Even With Key Off Joe Reeves Ford Crown Victoria 6 11-04-2008 10:54 PM
'90 F150 Runs lean/runs rough louchris Ford F-150 1 11-29-2007 11:58 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 03:13 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.