2011 Fiesta SES electrical issue - Ford Forum - Enthusiast Forums for Ford Owners

Aspire/Festiva/Fiesta Possibly one of the original "sub compacts" this car offered amazinf fuel economy.

2011 Fiesta SES electrical issue

Reply

 
 
 
  #1  
Old 06-24-2018, 05:41 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 1
Default 2011 Fiesta SES electrical issue

My problem is the battery light came on so then went and had alternator tested and results was it wasn't charging so went and had it rebuilt then re-installed and was charging but that pesky light would not go out! With car not running ok then crank and starts fine with no battery light but 20 seconds later boom light comes on so stop it start again boom here comes that light when the light comes on it pulls the motor a little but nothing major but it does it every time also u can turn the rear defogger on and its fine then battery light comes on then the rear defogger goes off and will not come back til ya turn car off then start it battery light comes on rear defogger goes off every time. I checked cables and connections and all the fuses I know to check but none are labeled battery, alternator, or charge! the rear defog fuse is ok! anyone know whats up please help
 
Reply With Quote
  #2  
Old 06-24-2018, 05:49 PM
Senior Member
Join Date: Jun 2010
Posts: 8,540
Default

This is a shot in the dark, but it could involve the BCM (body control module) or possibly the instrument cluster itself. It will require a capable scan tool to see what is happening and where the problem is originating.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
William Murar
Ford Focus
3
01-21-2018 08:14 AM
trev0006
Aspire/Festiva/Fiesta
0
06-05-2013 11:50 AM
cardiag12
PRIVATE For Sale / Trade Classifieds
0
05-16-2011 03:01 PM
stanchfi
Other Makes/Models owned by Ford Motor Company
0
03-21-2009 09:01 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory