1987 bronco 4.9l straight 6 issue - Ford Forum - Enthusiast Forums for Ford Owners

Ford Bronco One of the original SUVs, offered in both a full size Bronco, or the more compact Bronco II.

1987 bronco 4.9l straight 6 issue

Reply

 
 
 
  #1  
Old 04-25-2018, 10:22 AM
Junior Member
Thread Starter
Join Date: Apr 2018
Posts: 1
Default 1987 bronco 4.9l straight 6 issue

Hey guys I just got a 1987 Ford bronco with the 4.9l in-line 6. It has been sitting for about 2 years. Sometimes it is hard to start without starting fluid but when it starts it will start up every time until it sits overnight. It idles good but if you give it a lot of gas itís like it smothers out and almost dies until you let off. If you ease into the throttle it will rev up as high as you let it and it will hold at that rpm. The fuel pumps had good pressure. Has a new fuel pressure regulator and a new fuel pump relay. It was missing a vacuum hose from the vacuum tee to the map sensor. If you put that hose on it will start sputtering and almost dies. I know itís a lot but any help would be greatly appreciated
 
Reply With Quote
  #2  
Old 04-25-2018, 07:53 PM
Senior Member
Join Date: Jun 2010
Posts: 8,443
Default

Map sensor wire colors shoud be;
Blk-Wht = Grd
Drk Blu-Lt Grn= Signal to ECA
Org-Wht= 5 Volt Ref
With Key on engine off KOEO
Signal wire to ECA should read 1.55 - 1.63 Volts Anything else, replace MAP
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
87broncofrankinstien
New Member Area
3
02-10-2010 03:41 PM
benz_020
Ford Bronco
0
02-26-2006 09:11 PM
benz_020
PRIVATE For Sale / Trade Classifieds
0
02-26-2006 09:06 PM
CobieCane
Off Topic
7
09-07-2005 02:08 AM
semperfi48103
Ford F-150
3
08-30-2004 02:28 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory