Rear Wiper not working - Ford Forum - Enthusiast Forums for Ford Owners

Ford Escape The newest smaller SUV from Ford allows the buyer to have the use of an SUV without the hunger for fuel that so many SUVs display.

Rear Wiper not working

Reply

 
 
 
  #1  
Old 10-09-2018, 08:15 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 1
Question Rear Wiper not working

I have a 2011 ford escape and a replaced the rear wiper motor and 1 year later it has stopped working. When you turn on the switch it clicks and moves a few centimeters and stops. Please help.
 
Reply With Quote
  #2  
Old 10-10-2018, 03:31 PM
Senior Member
Join Date: Jun 2010
Posts: 8,742
Default

Not always, but a good part of the time a poor connection will offer high resistance to the circuit and not enough power will be available for the motor to operate properly.

Also,,,,,,,,depending on where you obtained the replacement motor can have some bearing on it's dependability.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
oldad
Ford Freestar
2
03-12-2018 12:33 AM
jjcar99
General Tech
13
08-16-2017 06:07 PM
reynard
Ford Explorer
0
01-06-2008 01:01 PM
dave2472
Ford Explorer
1
05-10-2007 04:43 AM
blkjak
Ford Taurus
0
12-09-2006 04:09 PM


Thread Tools
Search this Thread
Quick Reply: Rear Wiper not working


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.