'94 Escort, 1.9 liter, code 542 (Fuel Pump Open) - Page 2 - Ford Forum - Enthusiast Forums for Ford Owners


Reply
 
 
 
Thread Tools Search this Thread
  #11  
Old 02-21-2017, 02:41 PM
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 6
Default

I've been meaning to post an update but time isn't something I have a ton of these days.

It turned out to be the timing belt. The timing belt tensioner stopped turning, the friction caused the belt to heat up and start to melt to the tensioner wheel, and it seemed like the belt slid towards the head on the camshaft sprocket. When we got the cover off the belt was shredded near the head side of the sprocket. Replaced it, everything is good to go. Thanks for all the responses and advice, I appreciate everyone's willingness to help.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
CM code 542 after changing the fuel filter please help. FirstFordF250 Ford F-250 & Ford F-350 1 08-31-2013 09:53 PM
1993 Ford Taurus - code 542 - Fuel Pump to ECA robbyradio Ford Taurus 3 06-17-2013 04:10 PM
Fuel pump no power & cant locate fuel pump relay 94 f250 jozepy24 Ford F-250 & Ford F-350 0 05-23-2010 02:40 AM
1998 ranger 3.0 liter-fuel pump/relay issues badnews Ford Ranger 5 10-03-2007 10:05 PM
code 542? 1993 Taurus discusgary Ford Taurus 0 11-28-2005 12:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:06 AM.