Gas Gauge not working - Ford Forum - Enthusiast Forums for Ford Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-10-2017, 12:09 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 2
Default Gas Gauge not working

Hello,

I have a 2004 Ford Sport Trac XLT. Replaced fuel pump, sending unit and had cluster rebuilt. Gas gauge still not working. I fill the tank drive about 15 miles and gauge goes to empty.
Reply With Quote
  #2  
Old 09-11-2017, 11:32 AM
Hayapower's Avatar
Super Moderator

 
Join Date: Jul 2006
Posts: 5,321
Thumbs up

Welcome to the site..

When the gauge drops, does it stay down for the count until the tank is filled again?

The gauge works by the PCM supplying a reference voltage to the tank unit and a fuel level is sent back to the slosh Module as a signal return in an ohms value. Basically a varied ground. (Could ground the BK/OG and the gauge should peg Full)
Being the cluster was replace would/should take the Slosh Module off the table as a drop out to the gauge.

Excluding the cluster and tank connectors, there are a few other connectors inline for both PCM ref., and the sender to slosh for a sig. return.

There's two midship,, left side frame rail area about were the driver sits..
From those connectors you can measure resistance through the tank sender (Low fuel-22.5 ohms, Full-145 ohms) so if the gauge is reading Empty and the ohm value reads high through the connector when tested then the issue is forward of that connector or the PCM ref is missing. Same with the PCM Reference value into/for the tank unit. Checked/back probed at the connector the ref voltage for the gauge should be active there. If not, then the issue is forward within another connector or possibly PCM..

If your up for some testing, I can provide some check points...

Last edited by Hayapower; 09-11-2017 at 11:35 AM.
Reply With Quote
  #3  
Old 09-11-2017, 01:56 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 2
Default Gas Gauge

Hello,

Here is what usually happens. I fill the truck and the gauge goes to full. I drive for about 15-20 miles and it quickly goes to empty and beeps and the low fuel light comes on. I drive, shut the truck off when I am done. If I start it it will go back up to full and sometimes go to 3/4 full. Drive some more and it goes to E again. As I stated, cluster was rebuilt and fuel pump sending unit replaced. I do not know anything about fixing autos so I would rely info to a friend of mine.
Thanks so much for your help.
-D
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
gas gauge just stopped working soopacee Ford Freestar 4 04-17-2015 07:13 PM
90 probe gas gauge not working austio117 Ford Tempo/Probe 3 12-23-2014 06:04 PM
fuel gauge not working tfunk002 Ford Explorer 2 12-26-2006 10:24 PM
Gas Gauge not working blake General Tech 4 08-08-2006 01:43 PM
MOVED: Gas Gauge not working blake New Member Area 0 08-06-2006 12:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:03 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.