2004 Ford freestar rough running - Ford Forum - Enthusiast Forums for Ford Owners

New Member Area New to Ford Forum? Stop in tell us about you.

2004 Ford freestar rough running

  #1  
Old 02-09-2019, 06:27 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 2
Default 2004 Ford freestar rough running

04 freestar 4.2. Has code p0340 for cam sensor. At first wife was diving and it started to miss then stalled out while driving. Got to it and when started ran rough and could not hardly drive it in the parking lot. Towed home. Went over it. Now idles ok in park, but will not drive and stalls when you try. Seems to get worse when it warms up. Outside temp currently around freezing. Idle also goes to 2000rpm in neutral but normal in park. Ended up replacing cam sensor. Same issue. Also when I try to reverse it will it always engage you have to play with lever until it goes in but never had a problem with that before engine issue. Tried unplugging idle air control for fun. Lowered idle in both park and neutral. Even tried to drive it like that but it stalled out under speed. Any ideas please.
Also engine runs the same weather cam sensor plugged or unplugged.
 

Last edited by Rpacitti; 02-10-2019 at 02:39 PM. Reason: More info
  #2  
Old 02-10-2019, 01:33 PM
Senior Member
Join Date: Jun 2010
Posts: 8,858
Default

For what it is worth,
May not apply here, but
unplugging electrical components while the key is on or the engine is running is not recommended with today's vehicles because it can send voltage spikes into the system and the computers don't really like that and have a way of getting even.
If unplugged when the key is off no problem except the C/E lite could illuminate.
 
  #3  
Old 02-10-2019, 02:38 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 2
Default

Personally never had a problem unplugging a sensor and get a voltage spike. But have seen disconnecting and reconnecting batteries cause a voltage spike and fry an ecm on a CAT engine.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
romeodz
Ford Expedition
4
05-24-2015 11:23 PM
Videoguybob
Ford Econoline E Series
1
08-16-2011 09:19 PM
joshuathomason
General Tech
2
12-15-2009 08:24 AM
jds710
Ford Focus
2
12-05-2007 01:36 PM


Thread Tools
Search this Thread
Quick Reply: 2004 Ford freestar rough running


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.