66 F100 running issue - Ford Forum - Enthusiast Forums for Ford Owners

66 F100 running issue

Reply

 
 
 
  #1  
Old 04-23-2018, 09:49 AM
Junior Member
Thread Starter
Join Date: Apr 2018
Posts: 2
Default 66 F100 running issue

History of truck...It's a 1966 F100 with an early 70's 302 4bbl with a small block C6. Was not running when I got it, hadn't been driven in years. I Rebuilt the Holley 650, replaced the distributor with new,points one and new cap, rotor and plugs, replaced oil pump, replaced fuel pump and all rubber fuel lines, added in-line filter and cleaned fuel tank and all metal lines. Started up great and ran fine for the first couple of days. All of the sudden it began to act like it was starving for fuel after it the engine got warm. It would sputter for a short period and then die. It would start right back up so I don't think it's a vapor lock issue. Some times it only takes @ 5 minutes for this to happen, sometimes it can be driven for 15 - 20 minutes before it happens. The strangest part is, if driving it acts as though it's starving for fuel and sputtering and then all of the sudden it's running fine again. after it happens the first time it keeps coming and going. Any suggestions?
 
Reply With Quote
  #2  
Old 04-23-2018, 06:02 PM
Senior Member
Join Date: Jun 2010
Posts: 8,615
Default

I don't know if this is the problem, but the needle and seat that the float controlled was not always made to withstand unleaded fuel and would swell and give the symptoms of an erratic float level or low float level because it shut off too soon.
Worth looking into, what do you think?
 
Reply With Quote
  #3  
Old 04-23-2018, 06:21 PM
Junior Member
Thread Starter
Join Date: Apr 2018
Posts: 2
Default

Thank you for the input, it certainly seems like a fuel issue but never considered this. I'll check it out. Thanks again.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bassdude65
Ford Escort
0
03-10-2014 01:50 PM
Kmed16
Ford F-150
0
03-02-2012 09:03 PM
Samdiver74
Ford Ranger
4
05-16-2011 05:50 AM
sbcadillac
Ford F-250 & Ford F-350
4
03-25-2008 01:12 PM
96F350Panel
Ford Explorer
5
11-27-2007 02:59 PM


Thread Tools
Search this Thread
Quick Reply: 66 F100 running issue


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.