Trouble with 78 400 - Page 3 - Ford Forum - Enthusiast Forums for Ford Owners

Trouble with 78 400

  #21  
Old 02-24-2019, 02:31 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 18
Default


Finally here is a picture of the car. Its at my stepdads house. Ill have the title and plate next week.
 
  #22  
Old 02-24-2019, 05:56 PM
Hayapower's Avatar
Super Moderator
Join Date: Jul 2006
Posts: 6,140
Default

Looks nice
 
  #23  
Old 03-19-2019, 07:42 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 18
Default

Man this car has been a real pain. The timing was so far off it was ridiculous. Ive been driving it since Sunday. If everything works out I'll be driving it to the beach this weekend. The heater core is bad I'm going to bypass it until I get back. The voltage regulator went out today and the car left me stranded
 

Last edited by Mightyox; 03-19-2019 at 07:45 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
oneslickhotrod
Ford Performance
7
04-19-2008 01:29 PM
texashotrods
Member Group And Special Buys
0
07-03-2007 02:56 PM
vigilante4u2
PRIVATE For Sale / Trade Classifieds
0
02-11-2007 10:25 AM
IntergalaticMAN
General Tech
3
08-06-2005 09:03 PM
cctxfish
Off Topic
1
07-22-2005 01:32 AM


Thread Tools
Search this Thread
Quick Reply: Trouble with 78 400


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.