Need your help no Heat in front - Ford Forum - Enthusiast Forums for Ford Owners

Ford Expedition The Expedition provides the feel of a full size truck with the seating of a large SUV.

Need your help no Heat in front

Reply

 
 
 
  #1  
Old 01-06-2018, 04:11 PM
Junior Member
Thread Starter
Join Date: Nov 2012
Posts: 3
Default Need your help no Heat in front

I have a 2002 expo i have no heat in front but i have slight heat in back i have replaced thermostat, flushed heater core and still no heat so i figured blend door is open so instead of tearing out dash i cut the heater box cause the truck is old and ready for junk yard i cut the hole and closed the blend door figuring that would give me heat but no heat it almost feels like the ac is on why wouldnt i get any heat by closing the blend door Both heater hoses are hot to the touch
 
Reply With Quote
  #2  
Old 01-06-2018, 04:52 PM
Senior Member
Join Date: Jun 2010
Posts: 8,610
Default

When both heater hoses are the same temp it generally means the core is plugged. Flushing doesn't always clean out accumulated junk and replacement is the only cure.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tattooed_drew
Ford Econoline E Series
2
11-09-2017 08:00 PM
cve
Ford Econoline E Series
6
03-08-2017 06:15 PM
Use Common Sense
Ford Freestar
4
06-25-2016 01:30 PM
MeMaintain
General Tech
0
04-15-2013 09:21 PM
Budsjlm
General Tech
2
12-04-2009 10:34 AM


Thread Tools
Search this Thread
Quick Reply: Need your help no Heat in front


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.