trouble starting 2004 crown vic - Ford Forum - Enthusiast Forums for Ford Owners

Ford Forum Help & Suggestion Center Need help with FF? Ask. Have a suggestion to better FF? Tell us here.

trouble starting 2004 crown vic

  #1  
Old 08-09-2018, 01:43 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default trouble starting 2004 crown vic

started when jumped then that quit. Bought new battery but still won't start. Replaced starter, has power but still won't turn over. Any idea what could be wrong with it.
 
  #2  
Old 08-09-2018, 02:39 PM
Senior Member
Join Date: Jun 2010
Posts: 8,805
Default

When you turn the key to the start position just what do you get?
Clicks
grinding
nothing
So we are on the same page, when we are trying to get the engine to start running we crank it over
when it starts running it fires up. I realize won't start covers both of these but it is important to know just which one of these conditions is present.

If it won't crank over could be a completely different cause compared to it won't fire up. Thanks
 

Last edited by hanky; 08-09-2018 at 02:47 PM.
  #3  
Old 08-14-2018, 02:23 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default

the car does nothing except lights turning on. Now that it has been sitting for a while, the lights won't even turn on. Like I said it has a new starter and battery.
 
  #4  
Old 08-14-2018, 03:57 PM
Senior Member
Join Date: Jun 2010
Posts: 8,805
Default

It is possible it needed both of those parts, but with a new battery it should have done something.
Could you tell us which lights, dash lights headlights any other lights?
If your vehicle has a security system, tell us what does he anti-theft light do when you are attempting to start the vehicle.
Another possible problem is , what caused the battery to go dead if that is what happened,
Do the vehicle headlights work?
 
  #5  
Old 08-15-2018, 09:59 AM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default

With the new battery all lights came on including the anti-theft light. Now there are no lights whatsoever. Yes something caused the battery to go dead but that's what we are trying to figure out. We have a 1994 gmc truck that does the same thing. Except it starts when jumped.
 
  #6  
Old 08-15-2018, 05:46 PM
Senior Member
Join Date: Jun 2010
Posts: 8,805
Default

Have you solved the problem of the battery going dead ?
What steps have you taken so we don't go repeating things you already did and that did not help determine the cause of the problem.
 

Last edited by hanky; 08-15-2018 at 05:49 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
boz
Ford Crown Victoria
1
10-18-2012 05:15 PM
lloyd3
Ford Crown Victoria
5
12-16-2011 05:12 PM
gnorton52
Ford Crown Victoria
4
10-03-2010 08:57 PM
TroyBoy
Ford Crown Victoria
1
06-24-2009 07:51 PM
Deno
Ford Crown Victoria
8
12-06-2007 02:52 PM


Thread Tools
Search this Thread
Quick Reply: trouble starting 2004 crown vic


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.