06 Ford 500 P0340 - Ford Forum - Enthusiast Forums for Ford Owners

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

06 Ford 500 P0340

Reply

 
 
 
  #1  
Old 08-07-2018, 11:22 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 2
Default 06 Ford 500 P0340

2006 five hundred with active P0340 CMP fault code. Sensor has already been replaced. Any tips/help is appreciated.
 
Reply With Quote
  #2  
Old 08-09-2018, 02:08 PM
Senior Member
Join Date: Jun 2010
Posts: 8,615
Default

Sometimes connections/plugs at alternator can instigate this code, check if they are clean and tight.
 
Reply With Quote
  #3  
Old 08-11-2018, 05:24 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 2
Default P0340

Checked connections at alternator, looked ok. Also load tested the wiring from the sensor to the PCM and thatís ok as well. Itís also running rough and seems to be pre-detonating in the intake manifold. Thinking the timing chain possibly skipped a tooth?
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Nine8
Ford Econoline E Series
3
02-09-2014 06:02 AM
odar
Ford Econoline E Series
10
11-07-2011 09:45 PM
gskills
Ford Taurus
6
03-21-2008 10:01 PM
fcb11
Ford Ranger
4
12-19-2007 03:55 PM


Thread Tools
Search this Thread
Quick Reply: 06 Ford 500 P0340


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.