Hi new to the forum need help. - Ford Forum - Enthusiast Forums for Ford Owners

Hi new to the forum need help.

Reply

 
 
 
  #1  
Old 02-10-2018, 04:15 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Posts: 1
Post Hi new to the forum need help.

Hi I have a 1984 Ford LTD base model wagon with the 3.8L TBI Vin 3, my problem is I am having a problem trying to find out what throttle body goes on it cause the original was changed before i got the car and because of that the passing gear can not work properly, if anyone has any advice please let me know thank you
 
Reply With Quote
  #2  
Old 02-11-2018, 02:38 PM
Senior Member
Join Date: Jun 2010
Posts: 8,609
Default

If I remember correctly , though not very often, the throttle am pulls a link that goes down to the trans forward to change throttle pressure and drop back into "passing" gear. Do you have that on your vehicle? If not, what do you have?
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
weiss1172
New Member Area
2
09-20-2012 10:47 PM
AZ Dude
New Member Area
0
08-14-2010 02:26 PM
johno2355
Ford Forum Help & Suggestion Center
2
02-09-2010 05:00 PM
hounddog
New Member Area
0
05-01-2009 08:51 PM
pbnj08
Ford Excursion
2
12-14-2008 04:51 PM


Thread Tools
Search this Thread
Quick Reply: Hi new to the forum need help.


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.