2013 Edge dEad battery and rough ideal? - Ford Forum - Enthusiast Forums for Ford Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-09-2017, 09:33 PM
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 1
Default 2013 Edge dEad battery and rough ideal?

We have been experiencing a rough idle ( shuttering)when in park drainage on 2 brand new batteries as well as a low oil pressure light. What could this be?
Reply With Quote
  #2  
Old 03-10-2017, 03:04 AM
Senior Member
 
Join Date: Jun 2010
Posts: 7,230
Default

Some of the later model vehicles require that the computer be "notified" a new battery has been installed. This requires a capable scan tool.Until this is done the charging system will not work properly.
The low oil lite needs to be confirmed with a actual pressure gauge to confirm pressure is up to spec. What is done next is dependent on what gauge reading are obtained.
Rough idle problems can also be checked out with the scan tool. What kind of maintenance has been done to the vehicle?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Alldata 2013,mitchell onDemand 2013,esitronic 2013,elsa 2013 renatosc123 PRIVATE For Sale / Trade Classifieds 0 09-15-2013 04:08 AM
Dead Battery and low idle problems sunfish Ford Crown Victoria 2 11-05-2012 05:05 PM
Battery Drain, dead battery Captain B Ford Forum Help & Suggestion Center 1 09-21-2009 06:24 PM
Dead Battery pugmug Ford Thunderbird 7 04-15-2007 10:02 PM
Dead battery problem pugmug General Tech 3 07-12-2005 12:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:12 AM.