V10 Excursion won't start after GEM swap - Ford Forum - Enthusiast Forums for Ford Owners

Ford Excursion So the size of the Expedition is not enough for you, then the massive Excursion is the way to go. With options including a powerful diesel engine, the Excursion is like a tractor trailer built for family use.

V10 Excursion won't start after GEM swap

Reply

 
 
 
  #1  
Old 07-19-2018, 09:02 AM
Junior Member
Thread Starter
Join Date: Jul 2018
Posts: 9
Default V10 Excursion won't start after GEM swap

We had issues with the windows not working. I swapped the GEM. The windows work! Thought we were home free. Now it won't start. It wouldn't crank at first. I found a cut wire in the engine bay and fixed it. It now cranks. It started and drove fine a few months ago. We had bad oil pan, imagine that, it rusted through. Now it will retain oil with a small infrequent drip only. Since then, it's been sitting in the driveway.

We do hear the fuel pump prime.
It does crank
We do have fuel pressure in the rail after cycling the key (30-35 psi). If I purge the pressure, it will rebuild it when the key is cycled.
All the fuses look good (swapped the one for the fuel pump anyway.)
I have a spare fuse box, so I swapped the fuel pump relay.
I spray it with some starting fluid and it does kick off the fluid briefly.
I pulled off the air intake, so it has air.
There are not DTC codes
The "'theft" light does not flash while we're cranking it.
The battery is new and since we're cranking it a bunch, it's on a jumper / boost as needed.

I pulled a spark plug. Looks dry to me. No fuel.
Is there anything that would keep the injectors from spraying to keep it from starting?

Any help is appreciated.
 
Reply With Quote
  #2  
Old 07-19-2018, 10:55 AM
Senior Member
Join Date: Jun 2010
Posts: 8,615
Default

You could confirm power is available to the coils and injectors. (Fuses)

The PCM sends the ground signal to operate the coils and injectors.


Will it run if you used the original GEM ?
If so , the replacement GEM has a problem.
 
Reply With Quote
  #3  
Old 07-19-2018, 01:43 PM
Junior Member
Thread Starter
Join Date: Jul 2018
Posts: 9
Default

Originally Posted by hanky View Post
You could confirm power is available to the coils and injectors. (Fuses)

The PCM sends the ground signal to operate the coils and injectors.


Will it run if you used the original GEM ?
If so , the replacement GEM has a problem.
Coils work as the starting fluid will get it to kick over. Injectors I'm unsure.

Swap the GEM! Again! I'm taken that dumb thing out like 3 times. But, that is logical and I am getting good at it.

Thanks
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Richard Emil
Ford Excursion
1
07-09-2018 09:28 AM
fordosaurs
Ford F-250 & Ford F-350
3
12-08-2011 12:11 PM
bosanci28
Ford F-250 & Ford F-350
0
04-17-2010 11:33 PM
spenni1
Ford Explorer
1
04-25-2006 04:49 AM
spenni1
Ford Forum Help & Suggestion Center
0
04-24-2006 12:04 PM


Thread Tools
Search this Thread
Quick Reply: V10 Excursion won't start after GEM swap


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.