No Heat - Ford Forum - Enthusiast Forums for Ford Owners

Ford Five Hundred The new mid-sized luxury sedan, offering a powerful engine and all wheel drive.

No Heat

Reply

 
 
 
  #1  
Old 03-05-2018, 06:45 AM
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 4
Default No Heat

Hi First time here i have a 2006 ford 500 SEL AWD 3.0l i have no heat antifreez was low took a gallon to fill the tank and i ran to car for about an hour to warm it up and still no heat and the hoses are cold the fan kicks on and the temp gauge took forever to get to normal range any help would be great thanks in advance
 
Reply With Quote
  #2  
Old 03-19-2018, 05:36 PM
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 4
Default

UPdate got heat now found out it was air in the hoses bled it out and all set
 
Reply With Quote
  #3  
Old 03-19-2018, 07:25 PM
Senior Member
Join Date: Jun 2010
Posts: 8,605
Default

Thanks for the update.
Do you think it would be a good idea to find where the missing coolant went?
You might consider this a sort of warning that something is leaking. Unless you already checked it and found the answer.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tattooed_drew
Ford Econoline E Series
2
11-09-2017 08:00 PM
Use Common Sense
Ford Freestar
4
06-25-2016 01:30 PM
ricknags
Ford Econoline E Series
11
05-18-2013 06:53 AM
joshua.donelson
Ford Explorer
24
09-27-2005 08:03 AM
wallygator
Windstar/Aerostar
3
09-11-2005 01:08 AM


Thread Tools
Search this Thread
Quick Reply: No Heat


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.